Performance issues on www.dk-hostmaster.dk and www.difo.dk
Incident Report for .dk
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 17:11 CET
Investigating
We're currently experiencing performance issues on www.dk-hostmaster.dk and www.difo.dk. Our service provider is investigating the issue.
Posted Nov 28, 2022 - 15:11 CET
This incident affected: Website (www).