Customer support unable to handle requests
Incident Report for .dk
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 12:26 CET
Identified
Due to issues with one of our suppliers we are currently unable to handle calls and email in customer support. Your patience is very much appreciated.
Posted Jan 25, 2023 - 09:17 CET
This incident affected: Administrative services.